mountd − server for NFS mount requests and NFS access checks
/usr/lib/nfs/mountd [-v] [-r]
mountd is an RPC server that answers requests for NFS access information and file system mount requests. It reads the file /etc/dfs/sharetab to determine which file systems are available for mounting by which remote machines. See sharetab(4). nfsd running on the local server will contact mountd the first time an NFS client tries to access the file system to determine whether the client should get read-write, read-only, or no access. This access can be dependent on the security mode used in the remoted procedure call from the client. See share_nfs(1M).
The command also provides information as to what file systems are mounted by which clients. This information can be printed using the showmount(1M) command.
The mountd daemon is automatically invoked in run level 3.
Only super user can run the mountd daemon.
The following options are supported:
Reject mount requests from clients. Clients that have file systems mounted will not be affected.
Run the command in verbose mode. Each time mountd determines what access a client should get, it will log the result to the console, as well as how it got that result.
shared file system table
See attributes(5) for descriptions of the following attributes:
If nfsd is running, mountd must also be running in order to be assured that the NFS server can respond to requests, otherwise, the NFS service can hang.
Some routines that compare hostnames use case-sensitive string comparisons; some do not. If an incoming request fails, verify that the case of the hostname in the file to be parsed matches the case of the hostname called for, and attempt the request again.