NAME
libc − C library
SYNOPSIS
cc [ flag... ] file... -lc [ library ... ]
DESCRIPTION
Functions in this library provide various facilities defined by System V, ANSI C, POSIX, and so on. See standards(5). In addition, those facilities previously defined in the internationalization and the wide-character libraries are now defined in this library.
Many features in this library are implemented upon dynamic linking. Some of these features are not implemented in the archive version.
INTERFACES
The shared object libc.so.1 provides the public interfaces defined below. See intro(3) for additional information on shared object interfaces.
The following interfaces are unique to the 32-bit version of this library:
The following interfaces are unique to the 32-bit SPARC version of this library:
The following interfaces are unique to the 32-bit Intel version of this library:
The following interfaces are unique to the 64-bit SPARC version of this library:
FILES
/usr/lib/libc.a
archive library
/usr/lib/libc.so.1
shared object
/usr/lib/64/libc.so.1
64-bit shared object
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
SEE ALSO
pvs(1), intro(2), intro(3), attributes(5), lf64(5), standards(5)