Manpages

NAME

rwall − write to specified remote machines

SYNOPSIS

cc [ flag ... ] file ... -lrpcsvc [ library ... ]
#include <rpc/rpc.h>
#include <rpcsvc/rwall.h>

enum clnt_stat rwall(char *host, char *msg);

PROTOCOL

/usr/include/rpcsvc/rwall.x

DESCRIPTION

These routines require that the rpc.rwalld(1M) daemon be configured and available on the remote system indicated by host.

rwall() executes wall(1M) on host. The rpc.rwalld process on host prints msg to all users logged on to that system. rwall() returns RPC_SUCCESS if it was successful; otherwise a enum clnt_stat is returned which can be displayed using clnt_perrno(3NSL).

ATTRIBUTES

See attributes(5) for descriptions of the following attributes:

Image /var/www/mancx/application/src/../www/___/img/man3/man3/rwall1.png

SEE ALSO

rpc.rwalld(1M), wall(1M), rpc_clnt_calls(3NSL), attributes(5)