NAME
build — information on how to build the system
DESCRIPTION
The source for the FreeBSD system and applications are contained in three different directories, normally /usr/src, /usr/doc, and /usr/ports. /usr/src contains the ’’base system’’ sources, which is loosely defined as the things required to rebuild the system to a useful state. /usr/doc contains the source for the system documentation, excluding the manual pages. /usr/ports is a tree that provides a consistent interface for building and installing third party applications.
The make(1) command is used in each of these directories to build and install the things in that directory. Issuing the make(1) command in any directory or subdirectory of those directories has the same effect as issuing the same command in all subdirectories of that directory. With no target specified, the things in that directory are just built. The following list provides the names and actions for other targets:
clean
Removes any files created during the build process.
install
Installs the results of the build for this directory.
update
Gets updated sources as configured in /etc/make.conf.
The other /usr/src make targets are:
buildworld
Rebuild everything but the kernel, configure files in /etc, and release.
installworld
Install everything built by buildworld.
buildkernel
Rebuild the kernel and the kernel modules.
installkernel
Install the kernel and the kernel modules.
reinstallkernel
Reinstall the kernel and the kernel modules.
For more information about the ports build process, see ports(7).
ENVIRONMENT
TARGET_ARCH
The target machine processor architecture. This is analogous to the ’’uname −p’’ output. Set this to cross-build for a different architecture.
TARGET
The target hardware platform. This is analogous to the ’’uname −m’’ output. This is necessary to cross-build some target architectures. For example, cross-building for PC98 machines requires TARGET_ARCH=i386 and TARGET=pc98.
NO_WERROR
If defined, warnings will not cause the build to halt, even if the makefile says otherwise.
DESTDIR
The directory hierarchy where the resulting binaries will be installed.
FILES
/etc/make.conf
/usr/doc/Makefile
/usr/doc/share/mk/doc.project.mk
/usr/ports/Mk/bsd.port.mk
/usr/ports/Mk/bsd.sites.mk
/usr/share/examples/etc/make.conf
/usr/src/Makefile
/usr/src/Makefile.inc1
EXAMPLES
For an ’’approved’’ method of updating your system from the latest sources, please see the COMMON ITEMS section in src/UPDATING.
The following sequence of commands can be used to cross-build the system for the Alpha architecture on an i386 host:
cd /usr/src
make TARGET_ARCH=alpha buildworld
make TARGET_ARCH=alpha DESTDIR=/clients/axp installworld
SEE ALSO
cc(1), install(1), make(1), make.conf(5), ports(7), release(7), mergemaster(8), reboot(8), shutdown(8)
AUTHORS
Mike W. Meyer <mwm [AT] mired.org>.
BSD August 13, 2004 BSD